1 2 3
1 2 3
نمایش نتایج: از 1 به 5 از 5

موضوع: پیکربندی دامین کنترلر به منظور یکسان سازی خودکار تاریخ و ساعت کلاینتها

  1. #1
    امـــــ فور ــآی آنلاین نیست.
    کاربر عضو

    امـــــ فور ــآی آواتار ها
    تاریخ عضویت
    Feb 2013
    ارتباط با من
    امـــــ فور ــآی به Yahoo ارسال پیام
    نوشته ها
    30
    حالت من
    Mashghool
    میزان امتیاز
    0
    تشـکر
    0
    تشکرشده 0 بار در 0 ارسال
     

    Lightbulb پیکربندی دامین کنترلر به منظور یکسان سازی خودکار تاریخ و ساعت کلاینتها

    تنظیم تاریخ و ساعت کاربران در یک شبکه مبتنی بر دامین از اهمیت فوق العاده ای برخوردار است. Time Server که به NTP Server نیز شناخته می شوند با استفاده از در خواست کلاینت ها ( NTP Client ) از پورت UDP: 123 ، به آنها پاسخ می دهند. هر کلاینت می تواند به طور همزمان از چندین آدرس اعم از شبکه داخلی یا بستر اینترنت، درخواست زمان نماید.
    در شبکه بعضا دیده شده است که برخی از کلاینت ها می توانند به فایل های Share شده در روی یک File Server متصل گردند ولی بعضی از کاربران با پیغام خطای عدم تنظیم ساعت روبرو می گردند و نمی توانند به فایل های اشتراکی دسترسی داشته باشند و بعد از مدتی شرایط برای کاربران به العکس می شود. یا دیده می شود که برخی از پرینترهای Share شده، عملیات چاپ را انجام نمی دهند. یا OffLine شدن مکرر Exchnge و... شاید بتوان گفت یکی از دلایل، اختلاف زمانی زیادی است که بین کلاینت و File Server یا Print Server بوجود آمده است و باعث می شود که Authentication با شکست مواجه شود. ( بین 1 تا 5 ثانیه بعضا قابل قبول است! ) برای رفع این مشکل در شبکه های کوچک می توان از Time Server استفاده کنیم.
    در سناری پیش رو ، یک دستگاه میکروتیک را بعنوان Time Source قرار می دهیم و Domain Controller اصلی مان با FQDN: dc1.m4iir.local به این دستگاه متصل می کنیم (نقش PDC ) و سپس دامین کنترلر دوم DC2 را به دامین اصلی جهت دریافت تاریخ و ساعت ارتباط می دهیم ( Sync ). در نهایت با اجرای بچ فایلی در تمامی سیستم کلاینت ها، ساعت و تاریخ آنها را بر اساس دامین اصلی DC1 منطبق می کنیم.



    در این سناریو DC2 تایم خود را با سرور اصلی Sync می نماید. کلاینت ها نیز تایم خود را با دامین کنترلری که در دسترس است sync می کنند. این عملیات sync کردن در زمان Startup و نیز در حین کار، در بازه های زمانی خاص صورت می گیرد. یعنی سرویس Netlogon به دنبال دامین کنترلر می گردد تا بتواند ساعت و تاریخ را از آن دریافت نماید. هنگامی که دامین کنترلر را پیدا کرد یک درخواست برای دریافت تایم برای آن ارسال می نماید، که سرور جواب درخواست را برای آن کلاینت بر می گرداند. این عملیات که با پروتکل NTP صورت می پذیرد، باعث می شود که اگر ساعت کلاینت جلوتر یا عقب تر از سرور باشد، هنگام بوت شدن ویندوز، تایم جدید را از سرور دریافت نماید و با شبکه سنکرون گردد.
    قبل از شروع از باز بودن پورت 123 در سرور و کلاینها، دسترسی یوزر W32Time در ریجیستر دامین و غیر فعال بودن تنظیمات NTP در گروپ پالیسی و نیز تنظیم فایروال میکروتیک، اطمینان حاصل نمائید. ضمنا در تمامی سرورها و کلاینت ها تیک گزینه Automatically adjust clock for daylight savings changes فعال باشد.
    آیدی یاهو
    امـــــ فور ــآی به Yahoo ارسال پیام
    نوشته های وبلاگ
    0
    آدرس انجمن
    کلیک کنید

 
  • #2
    امـــــ فور ــآی آنلاین نیست.
    کاربر عضو

    امـــــ فور ــآی آواتار ها
    تاریخ عضویت
    Feb 2013
    ارتباط با من
    امـــــ فور ــآی به Yahoo ارسال پیام
    نوشته ها
    30
    حالت من
    Mashghool
    میزان امتیاز
    0
    تشـکر
    0
    تشکرشده 0 بار در 0 ارسال
     

    Arrow NTP Server و NTP Client در روتر برد میکروتیک

    با کاربر ادمین یا روت از طریق وین باکس به میکروتیک متصل شده و از منوی سمت چپ گزینه New Terminal را انتخاب کنید. سپس فرمان های زیر را به ترتیب وارد نمائید:
    کد:
    /system ntp client
    
    set enabled=yes primary-ntp=92.61.176.135 secondary-ntp=129.174.93.11
    در ادامه :
    کد:
    
    /system ntp server
    
    set broadcast=yes enabled=yes multicast=yes

    همچنین در ادامه دستورات تنظیم فایروال جهت اتصال رنج آی پی سرورها:
    کد:
    
    /ip firewall filter
    
    add chain=input comment="NTP Server Access" dst-port=123 protocol=udp src-address=192.168.12.64/26
    توضیح اینکه می توان فقط آی پی یا فقط نام سرور دامین کنترلر تان را وارد نمائید ( چنانچه تنظیمات DNS میکروتیک را صحیح انجام داده باشید ) و حتما این رول را به بالاترین رول های فایروال میکروتیک انتقال دهید. در ضمن آی پی در نظر گرفته شده برای Primary NTP کاملا اختیاریست.
    آیدی یاهو
    امـــــ فور ــآی به Yahoo ارسال پیام
    نوشته های وبلاگ
    0
    آدرس انجمن
    کلیک کنید

  •  
  • #3
    امـــــ فور ــآی آنلاین نیست.
    کاربر عضو

    امـــــ فور ــآی آواتار ها
    تاریخ عضویت
    Feb 2013
    ارتباط با من
    امـــــ فور ــآی به Yahoo ارسال پیام
    نوشته ها
    30
    حالت من
    Mashghool
    میزان امتیاز
    0
    تشـکر
    0
    تشکرشده 0 بار در 0 ارسال
     

    Cool time server در دامین کنترلر و راه اندازی سرویس NTP

    بر روی سرورها و کلاینها از مسیر کنترل پنل و سپس Date and Time تهران را بعنوان Time Zone انتخاب و تیک گزینه تغییرات اتوماتیک ساعتی، به منظور حداکثر استفاده از روشنایی روز را حتما فعال نمائید. ترجیحا در کنترل پنل Regional Options و زبانه Location کشور Iran را انتخاب نمائید.
    سپس در سرور DC1 موردنظر CMD را با راست کلیک و انتخاب گزینه Run As Administrator اجرا می نمائیم و چند خط فرمان زیر را ( به ترتیب ) در آن انتقال داده و اینتر می زنیم و در نهایت سیستم را ریستارت می نمائیم.
    کد:
    net stop w32time
    w32tm /config /manualpeerlist:MikroTik.m4iir.local /syncfromflags:MANUAL /reliable:yes /update
    net start w32time
    w32tm /resync /force
    چنانچه در شبکه دامینی Forest دارید ( نه Single Domain ) ، در دامین ثانویه از دستورات زیر استفاده نمائید:
    کد:
    
    net stop w32time
    w32tm /config /manualpeerlist:DC1.m4iir.local /syncfromflags:MANUAL /reliable:yes /update
    net start w32time
    w32tm /resync /force

    پس از مراحل فوق پیشنهاد می گردد تمامی کلاینتها و سرورها خاموش گردند و به ترتیب: اول DC1 روشن و قبل از نمایش صفحه Ctrl+Alt+Dlet ، سرور DC2 روشن گردد و پس از راه اندازی کامل این دو سرور مابقی دستگاهها روشن شوند. ( البته بهتر است تغییرات کلاینت ها نیز انجام شود و سپس تمامی سیستم ها خاموش و مجددا روشن و وارد شبکه شوند!! )
    برای تست دامین کنترلرها که نقش PDC Emulator را دارند وارد ریجیستر DC1 , DC2 شوید و از مسیر Registry زیر:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\W32Time\Config

    چنانچه برای کلید AnnounceFlags ارزش 10 در نظر گرفته باشد، می توان نتیجه گرفت که دستورات بالا بر روی دامین کنترلر مورد نظر به اجرا در نیامده است. ( ارزش 10 از مجموع دو ارزش 8 و 2 تشکیل شده است یعنی در سرویس Time، منظور از ارزش 8 عبارت است از: Automatic reliable time server و منظور از ارزش 2: Automatic time server ) ولی اگر دستورات فوق اجرا شده باشند، برای کلید AnnounceFlags ارزش 5 در نظر گرفته می شود ( ارزش 5 از مجموع دو ارزش 4 یعنی Always reliable time server و ارزش 1 یعنی Always time server تشکیل شده است ).

    اگر قبل از تغییرات فوق در دامین کنترل دستور زیر را اجرا کنید:

    کد:
     w32tm /query /source

    با پیغام Local CMOS Clock مواجه می شوید و پس از اعمال صحیح تنظیمات فوق در سرور DC1 آی پی میکروتیک یا هر دیوایس یا آدرس اینترنتی سایت NTP را نمایش می دهد و در سرور DC2 نام دامین کنترل DC1 را نمایش خواهد داد.
    آیدی یاهو
    امـــــ فور ــآی به Yahoo ارسال پیام
    نوشته های وبلاگ
    0
    آدرس انجمن
    کلیک کنید

  •  
  • #4
    امـــــ فور ــآی آنلاین نیست.
    کاربر عضو

    امـــــ فور ــآی آواتار ها
    تاریخ عضویت
    Feb 2013
    ارتباط با من
    امـــــ فور ــآی به Yahoo ارسال پیام
    نوشته ها
    30
    حالت من
    Mashghool
    میزان امتیاز
    0
    تشـکر
    0
    تشکرشده 0 بار در 0 ارسال
     

    Lightbulb Sync تاریخ و ساعت کلاینت ها با Server شبکه داخلی

    با فرض آنکه دامین کنترل ما به اینترنت دسترسی ندارد، میکروتیک را به عنوان NTP سرور به دامین کنترلر معرفی کردیم و دامین ثانویه را نیز متصل به DC1 نمودیم. حال در سیستم یکی از کابران بصورت ریموت یا لوکال با کاربری ادمین ، CMD را اجرا می کنیم و خط فرمان زیر را جهت مقایسه زمان کلاینت با سرور، اجرا می کنیم:

    کد:
     w32tm /stripchart /computer:DC1.m4iir.local /samples:4 /dataonly
    برای آنکه بدانیم کدام سرور نقش Time Server را بر عهده دارد، می بایست از دستور زیر و اطلاعاتی که در مقابل واژه RefID آمده است، استفاده نمائیم.

    کد:
     w32tm /monitor

    حال برای نهایی شدن تنظیمات در کامپیوتر کاربران دستورات زیر را به ترتیب در CMD اجرا می نمائیم:
    کد:
    TZCHANGE.exe /C "Middle East Standard Time" 
    TZCHANGE.exe /C "Iran Standard Time"
    net stop w32time
    w32tm /config /manualpeerlist:DC1.m4iir.local /syncfromflags:DOMHIER /update
    net start w32time
    net time \\DC1.m4iir.local /set /yes
    w32tm /resync
    می توانید برای اطمینان از صحت تغییرات، کامپیوتر کاربرتان را ریستارت نمائید. برای تست اعمال تغییرات فوق می توانید از ریجستر کلاینتها و مسیر :

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\W32Time\Parameters

    مقدار NtpServer می بایست نام DC1.m4iir.local باشد. ضمنا در کلاینتها همانند DC1 و DC2 نیازی نیست ارزش AnnounceFlags تغییر یابد!!!.
    تغییرات Automatically adjust clock for daylight savings changes نیز در مسیر ریجستری

    HKLM\SYSTEM\CurrentControlSet\Control\TimeZoneInfo rmation

    است که می توانیم TimeZoneInformation را حذف کرده و یا با تغییر Time Zone به شهر دیگر و Apply و سپس Daylight Saving Time یا به اختصار DST را به شهر تهران (GMT+3:30) Tehran تغییر دهیم، که در این صورت مجددا ساخته می شود.
    آیدی یاهو
    امـــــ فور ــآی به Yahoo ارسال پیام
    نوشته های وبلاگ
    0
    آدرس انجمن
    کلیک کنید

  •  
  • #5
    امـــــ فور ــآی آنلاین نیست.
    کاربر عضو

    امـــــ فور ــآی آواتار ها
    تاریخ عضویت
    Feb 2013
    ارتباط با من
    امـــــ فور ــآی به Yahoo ارسال پیام
    نوشته ها
    30
    حالت من
    Mashghool
    میزان امتیاز
    0
    تشـکر
    0
    تشکرشده 0 بار در 0 ارسال
     

    دانلود cscript و Batch File تنظیمات DTS در شبکه

    نکته بسیار مهم این است که در سرویس DHCP سرورهای دامین تان در هر اسکوپ بر روی Scope Options راست کلیک کرده و گزینه Configure Options را انتخاب نمائید. سپس در سربرگ General علاوه بر تنظیمات پیش فرض نصب Option های:

    کد:
    003 Router
    006 DNS Server
    015 DNS Domain Name
    حتماااا
    کد:
     004 Time Server
    را اضافه و آدرس آی پی همان سیستم که بالطبع یکی از دامین کنترلرهاست، قرار دهید. عموما نیازی به اضافه کردن
    کد:
     042 NTP Servers
    نمی باشد!!

    در پایان اشاره شود که تمامی موارد فوق از طریق اسکریپت، ریجستر و... خصوصا جهت اعمال و کانفیگ در شبکه های بزرگ توسط Group Policy قابل انجام است که می توانید لینک دانلود فایلهای مربوطه و آموزش های آن را دریافت نمائید. پیشنهاد می گردد در مورد تغییرات در ریجستر و اسکریپت ویندوز سرورهایتان بسیار حساس باشید و ترجیحا از اعمال تغییرات بصورت اتوماتیک ( توسط گروپ پالیسی و.. ) خودداری نمائید، تا دچار مشکلات حاد نگردید.


    موفق باشید
    آیدی یاهو
    امـــــ فور ــآی به Yahoo ارسال پیام
    نوشته های وبلاگ
    0
    آدرس انجمن
    کلیک کنید

  •  

    مجوز های ارسال و ویرایش

    • شما نمیتوانید موضوع جدیدی ارسال کنید
    • شما امکان ارسال پاسخ را ندارید
    • شما نمیتوانید فایل پیوست کنید.
    • شما نمیتوانید پست های خود را ویرایش کنید
    •  
    Top
    کلیه حقوق این سایت برای m4i.ir محفوظ است | پشتیبانی فنی امـــــ فور ــآی